Функция and в excel

Функция and в excel

Синтаксис функции

ЕНД(значение)

Значение — ссылка на ячейку или результат вычисления выражения, которое необходимо проверить.

Функция ЕНД() позволяет обработать ошибку #Н/Д. Откуда берется эта ошибка? Некоторые функции, например ПРОСМОТР() , ПОИСКПОЗ() или ВПР() могут вернуть ошибку #Н/Д (значение недоступно). Значение ошибки #Н/Д не очень информативно, поэтому вместо значения #Н/Д можно обработать, т.е., например, заменить #Н/Д на слово "Ошибка" или другое информационное сообщение типа "Значение не найдено" или "Введите другое число".

Например, если в ячейке Е2 содержится ошибка #Н/Д, то в любой другой пустой ячейке можно ввести формулу =ЕСЛИ(ЕНД(E2);"ОШИБКА!";E2)

Теперь если в ячейке Е2 содержится ошибка #Н/Д, то будет выведено слово ОШИБКА! (см. файл примера ).

Синтаксис функции

И(логическое_значение1; [логическое_значение2]; . )

логическое_значение — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ.

Например, =И(A1>100;A2>100)
Т.е. если в обеих ячейках A1 и A2 содержатся значения больше 100 (т.е. выражение A1>100 — ИСТИНА и выражение A2>100 — ИСТИНА), то формула вернет ИСТИНА, а если хотя бы в одной ячейке значение =И(ИСТИНА;ИСТИНА) вернет ИСТИНА,
а формулы =И(ИСТИНА;ЛОЖЬ) или =И(ЛОЖЬ;ИСТИНА) или =И(ЛОЖЬ;ЛОЖЬ) или =И(ЛОЖЬ;ИСТИНА;ИСТИНА) вернут ЛОЖЬ.

Функция воспринимает от 1 до 255 проверяемых условий. Понятно, что 1 значение использовать бессмысленно, для этого есть функция ЕСЛИ() . Чаще всего функцией И() на истинность проверяется 2-5 условий.

Совместное использование с функцией ЕСЛИ()

Сама по себе функция И() имеет ограниченное использование, т.к. она может вернуть только значения ИСТИНА или ЛОЖЬ, чаще всего ее используют вместе с функцией ЕСЛИ() :
=ЕСЛИ(И(A1>100;A2>100);"Бюджет превышен";"В рамках бюджета")

Т.е. если в обеих ячейках A1 и A2 содержатся значения больше 100, то выводится Бюджет превышен, если хотя бы в одной ячейке значение ИЛИ()

Читайте также:  Amd radeon r7 240 series характеристики

Функция ИЛИ() также может вернуть только значения ИСТИНА или ЛОЖЬ, но, в отличие от И() , она возвращает ЛОЖЬ, только если все ее условия ложны. Чтобы сравнить эти функции составим, так называемую таблицу истинности для И() и ИЛИ() .

Функция AND (И) в Excel используется для сравнения нескольких условий.

Что возвращает функция

Возвращает TRUE если значение или условие, при сравнении, соответствует критериям заданным в функции, или FALSE, в случае, если условие не соответствует критериям.

Синтаксис

=AND(logical1, [logical2],…) – английская версия

=И(логическое_значение1;[логическое_значение2];…)
– русская версия

Аргументы функции

  • logical1 (логическое_значение1) – первое условие, которое вы хотите оценить с помощью функции;
  • [logical2] ([логическое_значение2]) (не обязательно) – второе условие, которое вы хотите оценить с помощью функции.

Дополнительная информация

  • Функция может быть использована совместно с другими формулами;
  • Например, с помощью функции IF (ЕСЛИ ) вы можете проверить условие, а затем указать значение, когда оно TRUE, и значение, когда оно равно FALSE. Использование функции AND (И) вместе с функцией IF (ЕСЛИ) позволяет тестировать несколько условий за один раз;
    Например, если вы хотите проверить значение в ячейке A1 на предмет того, больше оно чем “0” или меньше чем “100”, то вы можете использовать следующую формулу:

=IF(AND(A1>0,A1 – английская версия

=ЕСЛИ(И(A1>0;A1 – русская версия

Ссылка на основную публикацию
Adblock detector