Mppe required but peer negotiation failed

Mppe required but peer negotiation failed

данные :
есть шлюз pptp на удалении.
шлюз пингуется.
шлюз настроен.

есть пк на ubuntu 14.04

sudo pptpsetup —create IDECO —server 79.133.116.2 —username вырезал —password вырезал —start —encrypt
using channel 2
Using interface ppp0
Connect: ppp0 /dev/pts/9
sent [LCP ConfReq > rcvd [LCP ConfReq > sent [LCP ConfAck > rcvd [LCP ConfReq > sent [LCP ConfAck > rcvd [LCP ConfRej > sent [LCP ConfReq > rcvd [LCP ConfAck > sent [LCP EchoReq > rcvd [LCP EchoReq > sent [LCP EchoRep > rcvd [CHAP Challenge >, name = "bill"]
sent [CHAP Response >, name = "вырезал"]
rcvd [LCP EchoRep > rcvd [CHAP Success ]
CHAP authentication succeeded
sent [CCP ConfReq > rcvd [CCP ConfReq > sent [CCP ConfNak > rcvd [CCP ConfAck > rcvd [CCP ConfReq > sent [CCP ConfAck > MPPE 128-bit stateless compression enabled
sent [IPCP ConfReq > sent [IPCP ConfReq > rcvd [IPCP ConfReq > sent [IPCP ConfAck > rcvd [LCP TermReq ]
LCP terminated by peer (MPPE disabled)
sent [LCP TermAck > rcvd [LCP TermReq ]
sent [LCP TermAck > rcvd [IPCP ConfRej > Discarded non-LCP packet when LCP not open
Script pptp 79.133.116.2 —nolaunchpppd finished (p > Modem hangup
Connection terminated.

Связался с Линуксом пару недель назад, так что, возможно, чего-то еще не знаю. Ситуация такая: на виртуальной машине, Centos 7 , не устанавливается VPN соединение через pptp. По логам что-то смог понять/исправить, что-то — нет. Ниже представлены сделанные мной настройки и логи:

После запуска (pppd call myvpn) tail -f /var/log/messages

Пробовал настроить через KDE (nm-connection-editor, можно ли его вообще настроить таким образом?), на что получил такое сообщение.

Читайте также:  Asus n550jk оперативная память

В итоге подозрения пали на то, что в ядре не хватает то ли драйверов, то ли модулей. Но опыт у меня в этом деле мизерный. Прошу подсказать знающих: что не так и как исправить?

Comments

Copy link Quote reply

olalonde commented Aug 1, 2015

I followed the tutorial to setup the PPTP server. It works when I connect directly from my Macbook but when trying to connect from router, the pptp.log shows this error: MPPE required but peer negotiation failed . On the router logs, I’m getting:

I suppose my router doesn’t support MPPE (whatever this is)? In that case, I suppose I would need to disable MPPE in my pptp.conf template?

This comment has been minimized.

Copy link Quote reply

olalonde commented Aug 1, 2015

Fixed by adding: pptp_require_mppe: false in my vars and commenting in pptp/templates/etc/ppp/pptpd-options :

Ссылка на основную публикацию
Adblock detector