Port security cisco настройка

Содержание
  1. Полезно
  2. Навигация
  3. Серверные решения
  4. Телефония
  5. Корпоративные сети
  6. Настройка Site-To-Site IPSec VPN на Cisco
  7. Настройка Router-on-a-Stick на Cisco
  8. Про CatOS (Catalyst Operating System)
  9. Стандартные листы контроля доступа (ACL)
  10. Настройка Cisco Port-Security
  11. Типы Port-Security
  12. Sticky MAC-адреса
  13. Пожалуйста, расскажите почему?
  14. Материал из Xgu.ru
  15. Содержание
  16. [править] Port security на коммутаторах ProCurve
  17. [править] Режимы запоминания адресов
  18. [править] Режимы реагирования на нарушения безопасности
  19. [править] Eavesdrop Prevention
  20. [править] Настройка port security
  21. [править] Отмена настройки port security
  22. [править] Включение порта после его блокировки
  23. [править] Настройка Eavesdrop Prevention
  24. [править] Настройка port security с аутентификацией 802.1X
  25. [править] Port security на коммутаторах Cisco
  26. [править] Безопасные MAC-адреса
  27. [править] Режимы реагирования на нарушения безопасности
  28. [править] Настройки по умолчанию
  29. [править] Настройка port security
  30. [править] Максимальное количество безопасных MAC-адресов
  31. [править] Настройка безопасных MAC-адресов
  32. [править] Настройка режима реагирования на нарушения безопасности
  33. [править] Очистка таблицы MAC-адресов
  34. [править] Настройка port security с аутентификацией 802.1X
  35. [править] Просмотр информации о настройках port security
  36. [править] Совместимость port security с другими функциями коммутатора

Полезно

Узнать IP — адрес компьютера в интернете

Онлайн генератор устойчивых паролей

Онлайн калькулятор подсетей

Калькулятор инсталляции IP — АТС Asterisk

Руководство администратора FreePBX на русском языке

Руководство администратора Cisco UCM/CME на русском языке

Серверные решения

Телефония

FreePBX и Asterisk

Настройка программных телефонов

Корпоративные сети

Протоколы и стандарты

Популярное и похожее

Настройка Site-To-Site IPSec VPN на Cisco

Настройка Router-on-a-Stick на Cisco

Про CatOS (Catalyst Operating System)

Стандартные листы контроля доступа (ACL)

Настройка Cisco Port-Security

Базовая сетевая безопасность

4 минуты чтения

Привет! Сегодня мы оговорим немного о базовой сетевой безопасности, а именно о Port-Security и о том, как его настроить на коммутаторах Cisco.

Для начала разберемся, что же вообще такое Port-Security. Port-Security – это функция коммутатора, при помощи которой мы можем указать каким устройствам можно пропускать трафик через определенные порты. Устройство определяется по его MAC-адресу.

Эта функция предназначена для защиты от несанкционированного подключения к сети и атак, направленных на переполнение таблицы MAC-адресов. При помощи нее мы можем указывать конкретные адреса, с которых разрешен доступ или указывать максимальное количество MAC-адресов, которые могут передавать трафик через порт.

Типы Port-Security

Существует несколько способов настройки port-security:

  • Статические MAC-адреса – MAC-адреса, которые вручную настроены на порту, из режима конфигурации порта при помощи команды switchport port-security mac-address [MAC-адрес] . MAC-адреса, сконфигурированные таким образом, сохраняются в таблице адресов и добавляются в текущую конфигурацию коммутатора.
  • Динамические MAC-адреса — MAC-адреса, которые динамически изучаются и хранятся только в таблице адресов. MAC-адреса, сконфигурированные таким образом, удаляются при перезапуске коммутатора.
  • Sticky MAC-адреса — MAC-адреса, которые могут быть изучены динамически или сконфигурированы вручную, затем сохранены в таблице адресов и добавлены в текущую конфигурацию.

Sticky MAC-адреса

Если необходимо настроить port-security со sticky MAC-адресами, которые преобразуются с из динамически изученных адресов и добавляются в текущую конфигурацию, то необходимо настроить так называемое sticky изучение. Для того чтобы его включить необходимо на интерфейсе коммутатора выполнить команду switchport port-security mac-address sticky из режима конфигурации интерфейса.

Когда эта команда введена, коммутатор преобразует все динамически изученные MAC-адреса (включая те, которые были динамически изучены до того, как было включено sticky обучение) к sticky MAC-адресам. Все sticky MAC-адреса добавляются в таблицу адресов и в текущую конфигурацию.

Также sticky адреса можно указать вручную. Когда sticky MAC-адреса настроены при помощи команды switchport port-security mac-address sticky [MAC-адрес], все указанные адреса добавляются в таблицу адресов и текущую конфигурацию.

Если sticky MAC-адреса сохранены в файле конфигурации, то при перезапуске коммутатора или отключении интерфейса интерфейс не должен будет переучивать адреса. Если же sticky адреса не будут сохранены, то они будут потеряны.

Если sticky обучение отключено при помощи команды no switchport port-security mac-address sticky , то эти адреса будут оставаться в таблице адресов, но удалятся из текущей конфигурации.

Обратите внимание, что port-security не будут работать до тех пор, пока не будет введена команда, включающая его — switchport port-security

Нарушение безопасности

Нарушением безопасности являются следующие ситуации:

  • Максимальное количество MAC-адресов было добавлено в таблицу адресов для интерфейса, а устройство, MAC-адрес которого отсутствует в таблице адресов, пытается получить доступ к интерфейсу.
  • Адрес, полученный или сконфигурированный на одном интерфейсе, отображается на другом интерфейсе в той же VLAN.

На интерфейсе может быть настроен один из трех режимов реагирования при нарушении:

  • Protect — когда количество MAC-адресов достигает предела, разрешенного для порта, пакеты с неизвестными исходными адресами отбрасываются до тех пор, пока не будет удалено достаточное количество MAC-адресов или количество максимально допустимых адресов для порта не будет увеличено. Уведомление о нарушении безопасности отсутствует в этом случае.
  • Restrict – то же самое, что и в случае Protect, однако в этом случае появляется уведомление о нарушении безопасности. Счетчик ошибок увеличивается
  • Shutdown – стандартный режим, в котором нарушения заставляют интерфейс немедленно отключиться и отключить светодиод порта. Он также увеличивает счетчик нарушений. Когда порт находится в этом состоянии (error-disabled), его можно вывести из него введя команды shutdown и no shutdown в режиме конфигурации интерфейса.
Читайте также:  Что такое csc в математике

Чтобы изменить режим нарушения на порту коммутатора, используется команда port-security violation в режиме конфигурации интерфейса.

Режим реагирования Передача траффика Отправка сообщения syslog Отображение сообщения об ошибке Увеличение счетчика нарушений Выключение порта
Protect Нет Нет Нет Нет Нет
Restrict Нет Да Нет Да Нет
Shutdown Нет Нет Нет Да Да
Настройка

Рассмотрим пример настройки:

Если мы не будем ничего уточнять и просто включим port-security командой switchport port-security в режиме конфигурации интерфейса, то максимальное количество адресов на порту будет один, sticky изучение будет выключено, а режим нарушения безопасности будет shutdown.

Проверка порта

Чтобы отобразить параметры port-security используется команда show port-security [номер_интерфейса] .

Чтобы отобразить все защищенные MAC-адреса используется команда show port-security address.

Пожалуйста, расскажите почему?

Нам жаль, что статья не была полезна для вас 🙁 Пожалуйста, если не затруднит, укажите по какой причине? Мы будем очень благодарны за подробный ответ. Спасибо, что помогаете нам стать лучше!

Подпишитесь на нашу еженедельную рассылку, и мы будем присылать самые интересные публикации 🙂 Просто оставьте свои данные в форме ниже.

Материал из Xgu.ru

Данная страница находится в разработке.
Эта страница ещё не закончена. Информация, представленная здесь, может оказаться неполной или неверной.

Если вы считаете, что её стоило бы доработать как можно быстрее, пожалуйста, скажите об этом.

Автор: Наташа Самойленко

Port security — функция коммутатора, позволяющая указать MAC-адреса хостов, которым разрешено передавать данные через порт. После этого порт не передает пакеты, если MAC-адрес отправителя не указан как разрешенный. Кроме того, можно указывать не конкретные MAC-адреса, разрешенные на порту коммутатора, а ограничить количество MAC-адресов, которым разрешено передавать трафик через порт.

Используется для предотвращения:

  • несанкционированной смены MAC-адреса сетевого устройства или подключения к сети,
  • атак направленных на переполнение таблицы коммутации.

Содержание

[править] Port security на коммутаторах ProCurve

[править] Режимы запоминания адресов

Port security может работать в нескольких режимах запоминания MAC-адресов и реагирования на нарушения:

  • Continuous — устройство с любым MAC-адресом может без ограничений работать через порт коммутатора.
  • Static — от 0 до 8 MAC-адресов могут быть статически заданы, остальные могут быть динамически выучены.
  • Configured — от 1 до 8 MAC-адресов могут быть статически заданы, динамически адреса выучены быть не могут.
  • Limited-continuous — от 1 до 32 MAC-адресов могут быть динамически выучены.
  • Port-access — используется вместе с 802.1X для того, чтобы временно выучить MAC-адрес аутентифицированной сессии 802.1X.

[править] Режимы реагирования на нарушения безопасности

Нарушением безопасности для port security считаются ситуации:

  • максимальное количество безопасных MAC-адресов было добавлено в таблицу адресов, и хост, чей MAC-адрес не записан в таблице адресов, пытается получить доступ через интерфейс.

На интерфейсе могут быть настроены такие режимы реагирования на нарушения безопасности:

  • none — когда количество безопасных MAC-адресов достигает максимального ограничения настроенного на порту, пакеты с неизвестным MAC-адресом отправителя отбрасываются до тех пор, пока не будет удалено достаточное количество безопасных MAC-адресов, чтобы их количество было меньше максимального значения, или увеличено максимальное количество разрешенных адресов. Оповещения о нарушении безопасности нет.
  • send-alarm — когда количество безопасных MAC-адресов достигает максимального ограничения, настроенного на порту, пакеты с неизвестным MAC-адресом отправителя отбрасываются до тех пор, пока не будет удалено достаточное количество безопасных MAC-адресов, чтобы их количество было меньше максимального значения, или увеличено максимальное количество разрешенных адресов. В этом режиме при нарушении безопасности отправляются SNMP trap и сообщение syslog.
  • send-disable — нарушение безопасности приводит к тому, что интерфейс переводится в заблокированное состояние и выключается немедленно. Отправляются SNMP trap и сообщение syslog. Когда порт в заблокированном состоянии — вывести его из этого состояния можно, введя команду port-security

clear-intrusion-flag, и затем вручную включить интерфейс, введя в режиме настройки интерфейса enable.

[править] Eavesdrop Prevention

Eavesdrop Prevention — функция, запрещающая передавать unicast-пакеты, которые передаются на неизвестные для коммутатора MAC-адреса, на порты, на которых она включена. Это не позволяет неавторизованным пользователям прослушивать трафик, который передается на MAC-адреса, удалённые из таблицы коммутации по таймауту (aged-out).

Eavesdrop Prevention не влияет на multicast и broadcast трафик. Коммутатор передает этот трафик через соответствующие порты независимо от того настроена ли на них port security.

Настройка port security на интерфейсе автоматически включает на этом интерфейсе Eavesdrop Prevention.

[править] Настройка port security

Настройка port security:

Параметры команды port-security:

  • learn-mode — режим запоминания MAC-адресов. По умолчанию все порты в режиме continuous.
  • action — действие, которое будет выполняться при нарушении:
  • none — не выполнять никаких действий
  • send-alarm — отправить сообщение о нарушении (SNMP, log)
  • send-disable — отправить сообщение о нарушении и выключить порт
  • address-limit — максимальное количество MAC-адресов, которое будет разрешено на порту:
    • Применяется к режимам static, configured и limited-continuous
    • Для static и configured значения от 1 до 8
    • Для limited-continuous — от 1 до 32
    • По умолчанию для всех режимов разрешен 1 MAC-адрес
    • mac-address — статическое задание разрешенных MAC-адресов для режимов static и configured.
    • clear-intrusion-flag — очистить intrusion flag для указанных портов. После этого можно включать порт, который выключился из-за нарушения port security.
    • [править] Отмена настройки port security

      Отмена настройки port security:

      Читайте также:  Распиновка материнской платы asrock

      [править] Включение порта после его блокировки

      Включение порта после того, как он был выключен port security:

      [править] Настройка Eavesdrop Prevention

      [править] Настройка port security с аутентификацией 802.1X

      Необходимо настроить port security в режиме запоминания port-access:

      Установить при настройке аутентификации 802.1X режим контроля auto:

      Port security и режим контроля аутентификации 802.1X:

      • Если аутентификация 802.1X настроена в режиме контроля auto (режим по умолчанию), то коммутатор запоминает MAC-адрес хоста с которого подключился аутентифицированный пользователь как безопасный,
      • Если аутентификация 802.1X настроена в режиме контроля authorized, то коммутатор запоминает MAC-адрес первого появившегося хоста как безопасный.

      [править] Port security на коммутаторах Cisco

      [править] Безопасные MAC-адреса

      Коммутатор поддерживает такие типы безопасных MAC-адресов:

      • Статические MAC-адреса:
      • задаются статически командой switchport port-security mac-address mac-address в режиме настройки интерфейса,
      • хранятся в таблице адресов,
      • добавляются в текущую конфигурацию коммутатора;
    • Динамические MAC-адреса:
      • динамически выучиваются,
      • хранятся только в таблице адресов,
      • удаляются при перезагрузке коммутатора;
      • Sticky MAC-адреса:
        • могут быть статически настроены или динамически выучены,
        • хранятся в таблице адресов,
        • добавляются в текущую конфигурацию коммутатора. Если эти адреса сохранены в конфигурационном файле, после перезагрузки коммутатора, их не надо заново перенастраивать.
        • [править] Режимы реагирования на нарушения безопасности

          Нарушением безопасности для port security считаются ситуации:

          • максимальное количество безопасных MAC-адресов было добавлено в таблицу адресов и хост, чей MAC-адрес не записан в таблице адресов пытается получить доступ через интерфейс,
          • адрес, выученный или настроенный как безопасный на одном интерфейсе, появился на другом безопасном интерфейсе в том же VLAN’е.

          На интерфейсе могут быть настроены такие режимы реагирования на нарушения безопасности:

          • protect — когда количество безопасных MAC-адресов достигает максимального ограничения настроенного на порту, пакеты с неизвестным MAC-адресом отправителя отбрасываются до тех пор, пока не будет удалено достаточное количество безопасных MAC-адресов, чтобы их количество было меньше максимального значения, или увеличено максимальное количество разрешенных адресов. Оповещения о нарушении безопасности нет.
          • restrict — когда количество безопасных MAC-адресов достигает максимального ограничения настроенного на порту, пакеты с неизвестным MAC-адресом отправителя отбрасываются до тех пор, пока не будет удалено достаточное количество безопасных MAC-адресов, чтобы их количество было меньше максимального значения, или увеличено максимальное количество разрешенных адресов. В этом режиме при нарушении безопасности отправляется оповещение — отправляется SNMP trap, сообщение syslog и увеличивается счетчик нарушений (violation counter).
          • shutdown — нарушение безопасности приводит к тому, что интерфейс переводится в состояние error-disabled и выключается немедленно, и выключается LED порта. Отправляется SNMP trap, сообщение syslog и увеличивается счетчик нарушений (violation counter). Когда порт в состоянии error-disabled, вывести из этого состояния его можно введя команду errdisable recovery cause psecure-violation или вручную включить интерфейс введя в режиме настройки интерфейса shutdown и no shutdown. Это режим по умолчанию.

          Режим protect не рекомендуется настраивать для транка. Этот режим выключает запоминание адресов, когда какой-либо VLAN достигает максимума адресов, даже если порт не достиг максимального ограничения.

          [править] Настройки по умолчанию

          На коммутаторах Cisco такие настройки по умолчанию для функции port security:

          • Port security — выключен.
          • Запоминание sticky-адресов — выключено.
          • Максимальное количество безопасных MAC-адресов на порту — 1.
          • Режим реагирования на нарушения — shutdown.
          • Время хранения адресов:
          • отключено. Значение aging time — 0,
          • для статических адресов — отключено,
          • тип времени — абсолютное.

          [править] Настройка port security

          Port security настраивается в режиме настройки интерфейса. На многих коммутаторах Cisco по умолчанию порт находится в режиме dynamic auto, однако этот режим не совместим с функцией port security. Поэтому интерфейс надо перевести в режим trunk или access:

          Включение port security на интерфейсе (после этого включены настройки по умолчанию):

          Так как после команды switchport port-security, сразу включается Port security с настройками по умолчанию, то ее стоит давать вначале только если настройки по умолчанию подходят.

          Если требуется исправить какие-то параметры, то сначала нужно их исправить, а затем включить функцию.

          [править] Максимальное количество безопасных MAC-адресов

          Максимальное количество безопасных MAC-адресов на интерфейсе или в VLAN:

          Например, на интерфейсе разрешить 2 MAC-адреса, а остальные настройки по умолчанию:

          Заданием опционального параметра vlan, при указании максимального количества безопасных MAC-адресов, можно ограничить количество MAC-адресов для VLAN или перечня VLAN (добавлено с версии IOS 12.2.37SE).

          Например, настроить транк и разрешить 20 MAC-адресов в VLAN 7:

          Если на интерфейсе fa0/3 возникнет нарушение безопасности в VLAN 7, например, появится 21 адрес, то заблокирован будет только трафик этого VLAN.

          Просмотр информации о настройках port-security для VLAN 7:

          Если вы запишите на порт меньше безопасных адресов, чем указано в значении switchport port-security maximum, то оставшееся количество свободных адресов дополнится динамическими адресами по принципу «кто первый встал того и тапки».

          Если компьютер подключен к сети через PC-порт ip телефона Cisco, и у вас отдельный vlan для телефонии, то телефон продублирует свой mac-адрес в двух vlan’ах. Настройка port-security в таком случае будет выглядеть следующим образом:

          [править] Настройка безопасных MAC-адресов

          Включение sticky запоминания адресов:

          [править] Настройка режима реагирования на нарушения безопасности

          Режим реагирования на нарушения безопасности (по умолчанию shutdown):

          Читайте также:  Счет на латыни до десяти

          Если порт был настроен (или оставлен по умолчанию) режиме реагирования shutdown, то при нарушении порт перейдет в состояние error-disabled.

          Посмотреть, что порт перешел в состояние error-disabled:

          [править] Очистка таблицы MAC-адресов

          Очистить таблицу MAC-адресов, для подключения других устройств:

          [править] Настройка port security с аутентификацией 802.1X

          [править] Просмотр информации о настройках port security

          [править] Совместимость port security с другими функциями коммутатора

          Port security несовместима с такими функциями коммутатора:

          • порт на котором включен DTP (switchport mode dynamic),
          • интерфейс переведенный в режим третьего уровня (no switchport),
          • SPAN destination port,

          Port security совместима с такими функциями коммутатора:

          В данной статье, я расскажу что такое Port Security и приведу пример настройки интерфейса коммутатора cisco с использованием этой функции.
          Port Security — это функция канального уровня, которая создана для предотвращения несанкционированной смены MAC адреса сетевого подключения. Также, данная функция ограждает коммутатор от атак, которые могут быть направлены на переполнение таблицы MAC адресов.
          С помощью Port Security можно ограничить (на канальном уровне) количество подключений (MAC адресов) на интерфейсе, а так же, при необходимости, ввести безопасные MAC адреса вручную (статические MAC адреса).
          Пример настройки Port Security на интерфейсе коммутатора cisco:


          Рисунок 1 — Типичное подключение IP телефона и компьютера к интерфейсу коммутатора.

          На рисунке 1 мы видим распространенное подключение устройств в больших организациях. Как правило к порту подключаются два устройства: IP телефон и компьютер пользователя. Пример конфига интерфейса коммутатора с использованием Port Security:

          interface FastEthernet0/1
          switchport access vlan 10
          switchport mode access
          switchport voice vlan 2
          switchport port-security
          switchport port-security maximum 2
          switchport port-security violation restrict

          На выше приведенном конфиге видно, что 10 влан настроен для компьютеров, 2 влан используется для IP телефонии. Далее, по фукнциям Port Security:
          — «switchport port-security» означает, что мы включили Port Security на данном интерфейсе;
          — «switchport port-security maximum 2» говорит о том, что только 2 MAC адреса, могут «светиться» на интерфейсе одновременно (MAC адрес телефона и компьютера);
          — «switchport port-security violation restrict» указывает режим реагирование на нарушение. Таким образом, если на данном интерфейсе одновременно «засветится» третий (неизвестный) MAC адрес, то все пакеты с этого адреса будут отбрасываться, при этом отправляется оповещение – syslog, SNMP trap, увеличивается счетчик нарушений (violetion counter).
          Немного расскажу о режимах реагирования на нарушение безопасности. Существует три способа реагирование на нарушение безопасности:
          — «switchport port-security violation restrict»;
          — «switchport port-security violation shutdown»;
          — «switchport port-security violation protect».
          Команду «switchport port-security violation restrict» я описал выше.
          Вторая команда — «switchport port-security violation shutdown» при выявлении нарушений переводит интерфейс в состояние error-disabled и выключает его. При этом отправляется оповещение SNMP trap, сообщение syslog и увеличивается счетчик нарушений (violation counter). Кстати, если интерфейс находится в состоянии error-disabled, то самым легким путем разблокировать его, является выключить и включить интерфейс (ввести в настройках интерфейса команду — «shutdown», а потом — «no shundown»).
          Если же на интерфейсе введена команда — «switchport port-security violation protect», то при нарушениях, от неизвестного MAC адреса пакеты отбрасываются, но при этом никаких сообщений об ошибках не генерируется.
          Какой именно способ выбрать дело каждого, но как мне кажется, «switchport port-security violation restrict» является оптимальной для большинства случаев.
          Идем дальше. Если необходимо, то можно статически ввести MAC адреса, тогда конфиг будет иметь вид:

          interface FastEthernet0/1
          switchport access vlan 10
          switchport mode access
          switchport voice vlan 2
          switchport port-security
          switchport port-security maximum 2
          switchport port-security violation restrict
          switchport port-security mac-address 0005.5E80.22A3
          switchport port-security mac-address 00E0.F75B.C101

          Теперь, только от этих двух MAC адресов (0005.5E80.22A3, 00E0.F75B.C101) на данный интерфейс будут разрешены входящие пакеты.
          Немного поговорим о MAC адресах. При использовании Port Security существуют такие типы MAC адресов:
          — Динамические;
          — Статические;
          — Sticky MAC адреса.
          Динамические MAC адреса хранятся в таблице коммутации, но удаляются при истечении «aging time» или при перезагрузке коммутатора.
          Статические адреса хранятся в таблице MAC адресов и записываются в памяти коммутатора. Не удаляются при истечении «aging time» и при перезагрузке свитча.
          Sticky MAC адреса могут быть внесены в таблицу коммутации статически (в ручную) или динамически выучены. Они хранятся в таблице коммутации и в памяти свитча. Не удаляются при истечении «aging time» или перезагрузке коммутатора.
          Хочу отметить, что при использовании Port Security «aging time» по умолчанию равен 0.
          Теперь, приведу не большой пример настройки Port Security с использованием Sticky MAC адресов:

          Switch#conf t
          Switch(config)#
          Switch(config)#interface fa0/1
          Switch(config-if)#
          Switch(config-if)#switchport mode access
          Switch(config-if)#switchport access vlan 10
          Switch(config-if)#switchport voice vlan 2
          Switch(config-if)#switchport port-security
          Switch(config-if)#switchport port-security maximum 2
          Switch(config-if)#switchport port-security mac-address 0005.5E80.22A3
          Switch(config-if)#switchport port-security mac-address sticky
          Switch(config-if)#switchport port-security violation restrict

          В примере приведенном выше, был сконфигурирован один MAC адрес статически («switchport port-security mac-address 0005.5E80.22A3»), а все остальные MAC адреса (в нашем случае еще один) будут выучены динамически, но записаны в память коммутатора («switchport port-security mac-address sticky»). Вот что мы увидим, если в привилегированном режиме введем команду — «show run int fa0/1»:

          «>

          Оцените статью
          Добавить комментарий