Разрешить идентификацию виртуальной локальной сети

Разрешить идентификацию виртуальной локальной сети

Итак, сегодня я покажу как принять и в дальнейшем использовать если Вы для различных сервисов и систем на хосте с поднятой системой виртуализации Hyper-V на Windows Server 2016 Standard (Rus) VLAN— cети пущенные через Trunk, а не Access.

Я описываю свой приобретаемый опыт и шпаргалку если вдруг что-то забуду, какие-либо нюансы и в виду этого руководствуюсь, что зачем выполнять одну задачу вспоминая, как ее решать если можно один раз составить заметку и обращаться к ней снова и снова по требованию.

Так вот все сервера подключены к коммутатору Dell EMC Switch S4128T-ON посредством двух сетевых карточек для отказоустойчивости. Затем на EMC создаю VLAN, к примеру:

configure terminal

interface vlan111

ip address 172.33.111.254/24

no shutdown

description vdi_network

exit

и назначен он не как access-порт куда физически подключен сервер, а как trunk, т.е. я на один физический интерфейс могу подать несколько виртуальных сетей:

interface range ethernet 1/1/19-1/1/20

switchport mode trunk

switchport trunk allowed vlan 50,111,112

no shutdown

Если вспомнить предыдущую заметку, то именем 50 я назвал VLAN DMZ сети.

Поднимаю для данной виртуальной сети DHCP— сервис, так удобнее чем прописывать все адреса вручную:

ip dhcp server

no disable

pool vdi

network 172.33.111.0/24

default-router 172.33.111.254

(если нужен доступ в интернет, то следует еще указать: dns-server и не забыть на оборудовании Cisco указать разрешающие правила для этой сети)

Теперь, когда определенным интерфейсам обозначено, что на них подаются определенные сети их нужно как-то принять . Т.к. с коммутатора на хост идет два линка, то имеет смысл объединить их на Windows Server 2016 Standard в Nic Teaming задействовав данную заметку. После чего устанавливаем роль Hyper-V если была не установлена.

Создаю виртуальный коммутатор на Hyper-V на основе интерфейса, созданного с применением Nic Teaming:

Win + R – control.exe – Просмотр: (Категория) – Мелкие значки – Администрирование – и запускаю Диспетчер Hyper-V, перехожу на «Действия»: «Диспетчер виртуальных коммутаторов»

Виртуальный коммутатор какого типа вы хотите создать?: отмечаю «Внешняя» и нажимаю кнопку «Создать виртуальный коммутатор». Именую его и его настройки:

  • Имя: vSwitch
  • Внешняя сеть: выбираю интерфейс объединенных интерфейсов с применениемNic Teaming
  • Разрешить управляющей операционной системе предоставлять общий доступ к этому сетевому адаптеру: отмечаю галочкой

И нажимаю «Применить» — «ОК» — «Да».

Теперь что хост заработал в определенном VLAN нужно создать виртуальную машину и указать что сетевой интерфейс использует коммутатор vSwitch и обозначить какой VLAN назначается виртуальной машине:

VM: W7X86 – (Оборудование) Установка оборудования – Сетевой адаптер – Добавить

  • Виртуальный коммутатор: vSwitch
  • Разрешить идентификацию виртуальной локальной сети: отмечаю галочкой
  • Код VLAN: указываю ID VLAN, в рамках этой заметки это 111

И нажимаю «Применить» — «ОК».

Запускаю виртуальную машину (также действия по изменению VLAN ID можно проводить и не выключая VM). И проверяю, что VM получила IP адрес обозначенного на нее VLAN если был поднять DHCP сервис, в противном случае придется прописать настройки сети вручную:

Читайте также:  Сразу короткие гудки при звонке

Win + R -> cmd.exe – ipconfig

  • IPv4-адрес: 172.33.111.1
  • Маска подсети: 255.255.255.0
  • Основной шлюз: 172.33.111.254

Что и требовалось, я разобрал в шагах как на Windows системе в среде виртуализации Hyper-V принимать Trunk порты и назначать необходимым виртуальным системам определенные VLAN назначенные на хост систему через Trunk. На этом я прощаюсь, с уважением автор блога Олло Александр aka ekzorchik.

Используйте прокси ((заблокировано роскомнадзором, используйте vpn или proxy)) при использовании Telegram клиента:

Поблагодари автора и новые статьи

будут появляться чаще 🙂

Карта МКБ: 4432-7300-2472-8059
Yandex-деньги: 41001520055047

Большое спасибо тем кто благодарит автора за практические заметки небольшими пожертвованиями. С уважением, Олло Александр aka ekzorchik.

Технический блог специалистов ООО"Интерфейс"

  • Главная
  • Настраиваем сеть в Hyper-V.

Настраиваем сеть в Hyper-V.

  • Автор: Уваров А.С.
  • 21.01.2014

Продолжая цикл статей посвященный виртуализации, сегодня мы поговорим о настройке сети в Hyper-V. Основное внимание мы уделим теории, а именно разберем как устроены виртуальные сети и как они взаимодействуют с реальными. Потому что, как показывает практика, многие администраторы, в отсутствие простых и понятных материалов по данному вопросу, вынуждены осваивать настройку сети в Hyper-V методом "научного тыка".

С одной стороны, ничего сложного в настройке сетей для виртуальных машин нет, с другой многие начинают путаться во всех этих адаптерах, с трудом понимая, где реальный, где виртуальный, и чем они друг от друга отличаются. Постараемся внести ясность.

За настройку сетей в Hyper-V отвечает Диспетчер виртуальных коммутаторов, если мы откроем его, то увидим следующую картину:

Как видим, нам доступно создание трех типов сетей: внешней, внутренней и частной. Разберемся подробнее, для чего нужны эти сети и в чем разница между ними.

Внешняя сеть

Самый распространенный тип сети, который позволяет виртуальным машинам взаимодействовать с внешними сетями и хостом. При ее создании необходимо выбрать один из физических сетевых адаптеров, через который данная виртуальная сеть будет соединяться с внешними сетями.

Как мы уже писали, основу виртуальной сети составляет виртуальный коммутатор. При создании внешней сети, Hyper-V создает виртуальный коммутатор, к которому через виртуальные сетевые адаптеры (vNIC) подключаются как виртуальные машины, так и хост. Физический адаптер отключается от хоста и по сути становится физическим портом виртуального коммутатора, через который он подключается к внешней сети.

В этом нетрудно убедиться, после создания внешней сети на хосте появляется Адаптер Ethernet для виртуальной сети Hyper-V, на который переносятся все настройки с физического адаптера.

А в свойствах физического адаптера остался только Расширяемый виртуальный сетевой коммутатор в Hyper-V.

В случае с внешней сетью следует четко понимать, что хост, точно также как и виртуальные машины, подключается к виртуальному коммутатору через виртуальный сетевой адаптер. Физический сетевой адаптер, после создания внешней сети становится портом виртуального коммутатора, через который он подключается к внешней сети. Поэтому все сетевые настройки хоста следует производить только на виртуальном сетевом адаптере.

Также имеется возможность создания внешних сетей, изолированных от хоста, в этом случае виртуальный сетевой адаптер не создается, а физический интерфейс отключается от хоста, обслуживая только виртуальный коммутатор. Для этого при создании внешней сети необходимо снять галочку Разрешить управляющей операционной системе предоставлять общий доступ к этому сетевому адаптеру.

Читайте также:  Почему пишет зарядка подключена но не заряжается

Данная конфигурация позволяет успешно виртуализировать пограничные сетевые устройства, надежно отвязав их от внутренней сети и хоста. Например, мы можем создать две внешних сети, одна из которых будет подключена к локальной сети, вторая к интернет и осуществлять выход во внешнюю сеть через роутер на виртуальной машине, при этом и хост, и локальная сеть будут надежно изолированы от интернет, несмотря на то, что кабель внешней сети физически будет подключен к сетевому адаптеру хоста.

Внутренняя сеть

Как следует из ее названия, внутренняя сеть предназначена для подключения виртуальных машин и хоста и не предусматривает соединения с внешними сетями. При ее создании также создается виртуальный сетевой адаптер для хоста, который оказывается подключен к виртуальному коммутатору внутренней сети и должен быть сконфигурирован в соответствии с настройками виртуальной сети.

К внешней сети хост остается подключен через физический адаптер, настройки которого не затрагиваются. Данная конфигурация чаще всего используется для учебных и исследовательских целей, позволяя создавать и моделировать различной сложности сетевые конфигурации не затрагивая рабочие сети предприятия.

Внутренняя сеть c NAT

Данная возможность появилась начиная с Windows Server 2016, Hyper-V Server 2016 и Windows 10. Подробнее читайте в нашей статье: Настраиваем сеть NAT в Hyper-V

Частная сеть

Частная сеть отличается от внутренней тем, что виртуальный коммутатор может быть подключен только к виртуальным машинам и изолирован от хоста.

Данный вид сетей может быть использован также в учебных и исследовательских целей, а также для создания изолированных участков сети, например DMZ.

В этом случае связь между внешней и частной сетью будет осуществляться через одну из виртуальных машин, которая должна быть подключена к обеим сетям.

Как видим, Hyper-V дает в руки администратора весьма гибкий и мощный инструмент, позволяющий создавать весьма сложные сетевые конфигурации и управлять ими.

Виртуальные локальные сети (VLAN) предлагают один из способов изоляции сетевого трафика. Virtual local area networks (VLANs) offer one way to isolate network traffic. Виртуальные ЛС настраиваются в коммутаторах и маршрутизаторах, поддерживающих 802.1 q. VLANs are configured in switches and routers that support 802.1q. Если вы настроили несколько виртуальных ЛС и хотите, чтобы между ними происходил обмен данными, необходимо настроить сетевые устройства, чтобы это разрешить. If you configure multiple VLANs and want communication to occur between them, you’ll need to configure the network devices to allow that.

Для настройки виртуальных ЛС потребуется следующее: You will need the following to configure VLANs:

  • Физический сетевой адаптер и драйвер, поддерживающие маркировку VLAN 802.1 q. A physical network adapter and driver that supports 802.1q VLAN tagging.
  • Физический сетевой коммутатор, поддерживающий маркировку VLAN 802.1 q. A physical network switch that supports 802.1q VLAN tagging.

На узле вы настроите виртуальный коммутатор, чтобы разрешить сетевой трафик на порте физического коммутатора. On the host, you’ll configure the virtual switch to allow network traffic on the physical switch port. Это для идентификаторов виртуальных ЛС, которые вы хотите использовать для внутренних целей с виртуальными машинами. This is for the VLAN IDs that you want to use internally with virtual machines. Затем настройте виртуальную машину, чтобы указать виртуальную ЛС, которую виртуальная машина будет использовать для всех сетевых подключений. Next, you configure the virtual machine to specify the VLAN that the virtual machine will use for all network communications.

Читайте также:  Toshiba qosmio x70 a l5s характеристики

Чтобы разрешить виртуальному коммутатору использовать виртуальную ЛС To allow a virtual switch to use a VLAN

Откройте диспетчер Hyper-V. Open Hyper-V Manager.

В меню действия выберите Диспетчер виртуальных коммутаторов. From the Actions menu, click Virtual Switch Manager.

В разделе виртуальные коммутаторывыберите виртуальный коммутатор, подключенный к физическому сетевому адаптеру, который поддерживает виртуальные ЛС. Under Virtual Switches, select a virtual switch connected to a physical network adapter that supports VLANs.

В области справа в разделе идентификатор виртуальной ЛС выберите включить идентификацию виртуальной локальной сети , а затем введите номер виртуальной ЛС. In the right pane, under VLAN ID, select Enable virtual LAN identification and then type a number for the VLAN ID.

Весь трафик, проходящий через физический сетевой адаптер, подключенный к виртуальному коммутатору, будет помечен заданным ИДЕНТИФИКАТОРом виртуальной ЛС. All traffic that goes through the physical network adapter connected to the virtual switch will be tagged with the VLAN ID you set.

Чтобы разрешить виртуальной машине использовать виртуальную ЛС To allow a virtual machine to use a VLAN

Откройте диспетчер Hyper-V. Open Hyper-V Manager.

В области результатов в разделе виртуальные машинывыберите соответствующую виртуальную машину, а затем щелкните правой кнопкой мыши Параметры. In the results pane, under Virtual Machines, select the appropriate virtual machine and then right-click Settings.

В разделе оборудованиевыберите виртуальный коммутатор, для которого настроена виртуальная ЛС. Under Hardware, select an virtual switch that’s set up with a VLAN.

В области справа выберите включить идентификацию виртуальной локальной сети, а затем введите тот же идентификатор виртуальной ЛС, который указан для виртуального коммутатора. In the right pane, select Enable virtual LAN identification, and then type the same VLAN ID as the one you specified for the virtual switch.

Если виртуальная машина должна использовать больше виртуальных ЛС, выполните одно из следующих действий. If the virtual machine needs to use more VLANs, do one of the following:

Подключите другие виртуальные сетевые адаптеры к соответствующим виртуальным коммутаторам и назначьте идентификаторы виртуальных ЛС. Connect more virtual network adapters to appropriate virtual switches and assign the VLAN IDs. Убедитесь, что правильно настроены IP-адреса и что трафик, который нужно маршрутизировать через виртуальную ЛС, также использует правильный IP-адрес. Make sure to configure the IP addresses correctly and that the traffic you want to route through the VLAN also uses the correct IP address.

Настройте адаптер Word виртуальной сети в режиме магистрали с помощью команды Set-вмнетворкадаптервлан командлет. Configure the virtual network word adapter in trunk mode using the Set-VMNetworkAdapterVlan cmdlt.

Ссылка на основную публикацию
Adblock detector