Роутер на палочке cisco

Роутер на палочке cisco

ShareIT — поделись знаниями!

Полезно

Узнать IP — адрес компьютера в интернете

Онлайн генератор устойчивых паролей

Онлайн калькулятор подсетей

Калькулятор инсталляции IP — АТС Asterisk

Руководство администратора FreePBX на русском языке

Руководство администратора Cisco UCM/CME на русском языке

Навигация

Серверные решения

Телефония

FreePBX и Asterisk

Настройка программных телефонов

Корпоративные сети

Популярное и похожее

Настройка Site-To-Site IPSec VPN на Cisco

Настройка GRE туннеля на Cisco

ACL check — анализ списков доступа сетевого оборудования Cisco

5 лайфхаков в консоли Cisco

Настройка Router-on-a-Stick на Cisco

4 минуты чтения

Router-on-a-stick (роутер на палочке) — это термин, часто используемый для описания схемы, состоящей из маршрутизатора и коммутатора, которые соединены с использованием одного канала Ethernet, настроенного как 802.1Q транк. Стандарт 802.1Q используется для тегирования трафика, для передачи информации о принадлежности к VLAN. В этой схеме на коммутаторе настроено несколько VLAN и маршрутизатор выполняет всю маршрутизацию между различными сетями или VLAN (Inter-VLAN routing).

Хотя некоторые считают, что термин «маршрутизатор на палочке» звучит немного глупо, это очень популярный термин, который широко используется в сетях, где нет коммутатора 3-го уровня.

Также такую схему иногда называют “леденец” – lollypop. Находите некоторое сходство?

Пример

Наш пример основан на сценарии, с которым вы, скорее всего, столкнетесь при работе с сетями VoIP. Поскольку реализации VoIP требуют разделения сети передачи данных и сети голоса для маршрутизации пакетов между ними, вам необходим либо коммутатор 3-го уровня, либо маршрутизатор. Эта конфигурация обеспечивает доступность и стабильность VoIP, особенно в часы пик трафика в вашей сети.

Пакеты, передающиеся между VLAN маршрутизируются через один роутер, подключенный к коммутатору, используя один физический порт, настроенный как транк на обоих концах (коммутатор и маршрутизатор).

Этот пример покажет вам, как настроить маршрутизатор и коммутатор Cisco для создания между ними 802.1Q транка и маршрутизации пакетов между вашими VLAN.

Шаг 1 – Настройка коммутатора

Первым шагом является создание необходимых двух VLAN на нашем коммутаторе Cisco и настройка их с IP-адресом. Поскольку все коммутаторы Cisco содержат VLAN1 (VLAN по умолчанию), нам нужно только создать VLAN2.

Далее, нам нужно создать транк порт, который будет соединятся с маршрутизатором. Для этой цели мы выберем порт GigabitEthernet 0/1

При помощи данных команд мы определили, что транк будет использовать инкапсуляцию 802.1Q, установили порт в режим транка и включили функцию portfast trunk spanning-tree, чтобы гарантировать, что порт будет пересылать пакеты немедленно при подключении к устройству, например, маршрутизатору. Внимание: команда spanning-tree portfast trunk не должна использоваться на портах, которые подключаются к другому коммутатору, чтобы избежать петель в сети.

Читайте также:  Запрос к dns серверу
Шаг 2 – Настройка маршрутизатора

Мы закончили с коммутатором и можем переходить к настройке конфигурации нашего маршрутизатора, чтобы обеспечить связь с нашим коммутатором и позволить всему трафику VLAN проходить и маршрутизироваться по мере необходимости.

Создание транка на порте маршрутизатора не сильно отличается от процесса, описанного выше — хотя мы транк на одном физическом интерфейсе, мы должны создать под-интерфейс (sub-interface) для каждого VLAN.

Чтобы сформировать транк с нашим коммутатором, необходимо создать один под-интерфейс для каждого VLAN, сконфигурированного на нашем коммутаторе. После создания под-интерфейса мы назначаем ему IP-адрес и устанавливаем тип инкапсуляции 802.1Q и указываем номер VLAN, к которому принадлежит под-интерфейс.

Например, команда encapsulation dot1q 2 определяет инкапсуляцию 802.1Q и устанавливает под-интерфейс на VLAN 2.

Параметр native который мы использовали для под-интерфейса gigabitethernet0/1.1, сообщает маршрутизатору, что нативный vlan — это VLAN 1. Это параметр по умолчанию на каждом коммутаторе Cisco и поэтому должен совпадать с маршрутизатором.

Для проверки можно использовать на роутере команду show vlans, где будут отображены созданные нами под-интерфейсы, а также при помощи команды show ip route в таблице маршрутизации мы должны увидеть наши под-интерфейсы.

Готово! Теперь при помощи роутера мы можем маршрутизировать файлы между разными VLAN.

Пожалуйста, расскажите почему?

Нам жаль, что статья не была полезна для вас 🙁 Пожалуйста, если не затруднит, укажите по какой причине? Мы будем очень благодарны за подробный ответ. Спасибо, что помогаете нам стать лучше!

Подпишитесь на нашу еженедельную рассылку, и мы будем присылать самые интересные публикации 🙂 Просто оставьте свои данные в форме ниже.

Автор Гапон Анатолий создана 24. Nov, 2010 категория Routing, Other

В этой статье описывается пример маршрутизации между vlans ,другими словами это называется настройка router one a stick , с помощью sub-interfaces на маршрутизаторе . Как известно , vlans позволяют легко управлять отдельными областями сети и повышают безопасность , хочу напомнить что по умолчанию все порты коммутатора находятся в vlan 1 . И так, мы создаем три vlans , в каждом из которых настроена своя ip-область. В vlan 50 входят стационарные компьютеры из сети 50.0.0.0/24 , в vlan 200 входят ноутбуки , на практике этот vlan может использоваться как гостевой или для командировочных рабочих, ip-сеть этого vlan 200.0.0.0/24 , и vlan 100 , в котором находятся серверы web из сети 100.0.0.0/24. Теперь перейдем к конфигурации, с начала добавим порты коммутатора в нужные vlans . Vlan 50 содержит порты fa 0/2, fa 0/3 , fa 0/4. В vlan 200 входят порты fa 0/10 , fa 0/11 , fa 0/12 , а vlan 100 принадлежат порты fa 0/20 , fa 0/21.

Читайте также:  Как переехать из провинции в москву

Для простоты добавления интерфейсов в vlan используется команда : interface range fastEthernet
после которой нужно дописать диапазон интерфейсов, для которых будут применяться одинаковые настройки.

Switch#conf t Switch(config)#interface range fastEthernet 0/2-4 Switch(config-if-range)#switchport access vlan 50

Switch#conf t Switch(config)#interface range fastEthernet 0/10-12 Switch(config-if-range)#switchport access vlan 200

Switch#conf t Switch(config)#interface range fastEthernet 0/20-21 Switch(config-if-range)#switchport access vlan 100

После добавления портов в vlans , автоматически создается vlan с соответствующим номером.
Чтобы убедиться что порты в нужных vlans используем команду : show vlan

На интерфейс , который подключен к маршрутизатору устанавливаем режим порта как trunk , это необходимо для обмена трафиком между vlans ,в данном случае это interface fa 0/1.

Switch#conf t Switch(config)#interface fastEthernet 0/1 Switch(config-if)#switchport mode trunk

Посмотреть какие интерфейсы находятся в режиме trunk можно с помощью команды
show interfaces trunk

Устанавливаем настройки стека на каждом устройстве , подключенном к коммутатору соответственно адресной схеме, имеется ввиду ip-address и шлюз по умолчанию . Шлюз должен соответствовать адресу на определенном sub-interface маршрутизатора.
Проверяем доступность хостов в одной сети:

За тем проверим что другие сети не доступны, хотя это и так очевидно!

Адресная схема выглядит так :

Для начала включаем физический интерфейс , подключенный к коммутатору командой no shutdown .

Router#conf t Router(config)#interface fastEthernet 0/0 Router(config-if)#no shutdown

Далее настраиваем sub-interfaces :
Обратите внимание на то что после команды encapsulation dot1Q необходимо указать номер vlan и адрес с той же под-сети что и у оборудования , подключенному к портам коммутатора соответствующего vlan.

Настраиваем sub-interface для vlan 50:

Router#conf t Router(config)#interface fastEthernet 0/0.50 Router(config-subif)#encapsulation dot1Q 50 Router(config-subif)#ip address 50.0.0.254 255.255.255.0

Настраиваем sub-interface для vlan 100:

Router#conf t Router(config)#interface fastEthernet 0/0.100 Router(config-subif)#encapsulation dot1Q 100 Router(config-subif)#ip address 100.0.0.254 255.255.255.0

Настраиваем sub-interface для vlan 200:

Router#conf t Router(config)#interface fastEthernet 0/0.200 Router(config-subif)#encapsulation dot1Q 200 Router(config-subif)#ip address 200.0.0.254 255.255.255.0

Настройка sub-interfaces на маршрутизаторе выглядит так:

На этом конфигурация закончена !
Для проверки откроем web страничку на сервере :

Контрольный пинг в соседние сети :

Ниже приведен сконфигурированный пример для скачки.

Read this article in English

Для настройки взаимодействия между несколькими виртуальными сетями (Vlan), расположенными на одном коммутаторе, необходим маршрутизатор, подключенный к коммутатору через Trunk порт. При передаче трафика по этому порту каждый пакет помечается номером Vlan, которому принадлежит. Это позволяет устройствам корректно перенаправлять пакеты.
На этом интерфейсе настраиваются сабинтерфейсы (subinterfaces) с соответствующими ip адресами для каждой из сетей Vlan.
Ниже приведен пример настройки Trunk порта маршрутизатора Cisco 2811 для связи с коммутатором.

Видео версия этой статьи

Зайдите в режим конфигурирования (conf t)
R-DELTACONFIG# conf t
Выберите интерфейс FastEthernet0/0 и очистите его
interface FastEthernet0/0
no shut
no ip address

Читайте также:  Как проверить цвета на телефоне

Настройка интерфейса для сети управления оборудованием. Здесь не ставим точку после названия и не указываем идентификатор. Vlan. Это Vlan 1 по умолчанию.
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
Настройка сабинтерфейса для сети отдела продаж
interface FastEthernet0/0.10
encapsulation dot1q 10
ip address 192.168.10.1 255.255.255.0
description Sales
Настройка сабинтерфейса для сети бухгалтерии

interface FastEthernet0/0.20
encapsulation dot1q 20
ip address 192.168.20.1 255.255.255.0
description Account
Настройка сабинтерфейса для сети администраторов
interface FastEthernet0/0.100
encapsulation dot1q 100
ip address 192.168.100.1 255.255.255.0
description Admins

Важно!
На каждом интерфейсе рекомендую подписывать предназначения сетей командой description. Это поле никак не влияет на другие настройки, однако делает конфигурацию более удобной для восприятия.

Важно!
Обратите внимание, что рядом с указанием инкапсуляции (encapsulation dot1q 20) и в названии сабинтерфейса (interface FastEthernet0/0.20) стоит цифра, обозначающая номер Vlan (20). При этом порядковый номер сабинтерфейса может быть любым, но в строчке с настройкой инкапсуляции обязательно должен быть номер того Vlan, которому принадлежит сеть.
На коммутаторе помимо access портов, к которым подключены пользователи различных Vlan, должен быть сконфигурирован такой же trunk порт. (Как это сделать описано здесь)
Убедившись, что на коммутаторе настроен trunk порт и созданы Vlan с соответствующими номерами (10, 20 и 100), следует соединить его с интерфейсом FastEthernet0/0 маршрутизатора.
Для взаимодействия устройств из разных Vlan необходимо, чтобы:

  • каждая рабочая станция была подключена к порту коммутатора, на котором настроен соответствующий ей Vlan
  • На портах, куда подключаются рабочие станции должны присутствовать строчки вида
    switchport access vlan Х
    Например для бухгалтерии:
    switchport access vlan 20
  • каждая рабочая станция должна иметь ip адрес в соответствующей сети
    Рабочая станция в отделе продаж будет иметь адрес 192.168.10.5 255.255.255.0
  • на каждой рабочей станции в сетевых настройках в качестве шлюза по умолчанию должен быть указан ip адрес сабинтерфейса маршрутизатора того же Vlan, что и рабочая станция. Например для сети отдела продаж это 192.168.10.1
  • все используемые порты коммутатора и маршрутизатора должны быть включены

Команда show ip inter brief покажет состояния всех интерфейсов. Используемые должны быть в состоянии Up/Up.

Результатом настройки должна стать доступность друг другу всех объектов сети (как рабочих станций, так и интерфейсов маршрутизатора). Проверять следует командой ping с любого хоста или маршрутизатора.

Важно!

Не забудьте сохранить конфигурацию всех устройств командой write или copy run start. Иначе после перезагрузки все изменения будут потеряны.
R-DELTACONFIG# write
Building configuration.
[OK]

Ссылка на основную публикацию
Adblock detector